Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/proudft/public_html/smf_forum/Sources/Load.php(225) : runtime-created function on line 3
Natuk Patch 1.30 (Experimental)
Tom Proudfoot's Games
March 18, 2019, 10:11:15 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: New forums!  All information is here now.

 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Natuk Patch 1.30 (Experimental)  (Read 12015 times)
Tom Proudfoot
Emperor
Orc Warrior

Posts: 60


View Profile Email
« on: August 09, 2009, 09:42:09 am »

Well, the "new" compiler seems to be working as best as I can tell, so out into the wild it goes!

Patch 1.30 is just two changes:
- new compiler
- added scroll delay to the spell selection menu

It is quite likely that there are some strange side effects somewhere from the new compiler and this hasn't been extensively tested, I'm calling it experimental for now.  But a lot of people need that spell menu slowed down.

Download (800k)
http://www.proudft.com/natuk_update_130.zip


Logged
SkeleTony
Orc Warrior

Posts: 84


View Profile Email
« Reply #1 on: August 09, 2009, 10:38:12 am »

WOOHOO!
Logged
SkeleTony
Orc Warrior

Posts: 84


View Profile Email
« Reply #2 on: August 09, 2009, 11:22:51 am »

Ok, I just now played around with it a bit, using a saved game where my party is in the Jagg Sewers(so not far from the end). The slower scrolling spell menu is MUCH better than the too-fast scrolling menu. However...when you get to where you have a LONG list of spells you know, the scrolling is now TOO slow. Still much better than 'too fast' but if there were some way you could implement some way to either speed up the scrolling, via a mouse button push(while scrolling) or a setting in the options menu to control how fast the menu scrolls, that would be great.

I have fought two battles so far and not seen any weird bugs or anything like that so...I will keep plugging away as I find time.

Thanks again Tom!
Logged
JCAnejo
Whelpling

Posts: 1


View Profile Email
« Reply #3 on: August 09, 2009, 03:12:34 pm »

Cool Thanks
Logged
Pops
Whelpling

Posts: 1


View Profile
« Reply #4 on: August 24, 2009, 06:43:54 pm »

Tom,

I want to thank you for all your hard work before I attempt to install 3.00.
Of course I love this game, just right for me, gives me time to think before I react.

Thanks again,
Pops the old
Logged
SkeleTony
Orc Warrior

Posts: 84


View Profile Email
« Reply #5 on: August 27, 2009, 09:16:58 pm »

Think I may have found a bug. I just switched over to a new PC so this COULD be something screwy on my end.

I installed Natuk and then patched it with the 1.30 as per normal. I then replaced each of the "Custom1-Custom8.pcx" files with my customs. But now when I try to change the icon for any PC all of the 'custom' icons show up only as a diagonal yellow band going from the top right to the bottom left and if you click one of them the icon kind of cycles through a piece of text(like the wording below the actual icons that tells what frame is what), the yellow band and something else.
Logged
Tom Proudfoot
Emperor
Orc Warrior

Posts: 60


View Profile Email
« Reply #6 on: August 30, 2009, 10:14:34 pm »

Oooh, neat.  Might be the .pcx loading code, I'll look into it.
Logged
shiantar
Orc Scout

Posts: 13


View Profile
« Reply #7 on: September 18, 2009, 08:39:40 am »

Hi Tom,

The new scrolling delay works amazingly well with the spell list.

'Not to sound picky, but I was wondering if you'd given any thought to applying this same fix to the inventory lists for stores / looting when there are more than two pages of objects to sort through. The workaround (for me, anyway) is just to grab everything in sight and then drop the less valuable stuff.

The scroll delay would probably be useful here too, but I'm not certain how re-usable the code is.
Logged
Duuvian
Orc Scout

Posts: 13


View Profile
« Reply #8 on: September 30, 2009, 11:10:11 pm »

HOLY COW A NEW NATUK PATCH!

That's the sweetest thing I've seen all day and maybe yesterday too. I'll give it a try once I find my copy.
Logged
SkeleTony
Orc Warrior

Posts: 84


View Profile Email
« Reply #9 on: January 27, 2010, 07:49:52 pm »

Nevermind Tom. I uninstalled and removed the entire folder then re-installed. Then I added each patch(starting with the 1.27 patch) incrementally, checking the custom graphics each time along the way and now everything works fine. I have no idea why it was screwed up before but now the customs work as normal.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.8 | SMF © 2006-2008, Simple Machines LLC Valid XHTML 1.0! Valid CSS!